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CHAPTER TWO: EDITING AND VIEWING WORKSHEETS 

 

This Chapter Will Include: 

 Selecting Cells 
 Entering Text 
 Editing and Deleting Text 
 Hiding and Unhiding Rows and Columns 
 Using the Undo and Redo Features 
 Copying and Pasting Text 
 Using the Page Break Preview View 

 Using the Page Layout View 
 

 
 

 

Selecting Cells 

You can use the mouse and keyboard to select multiple cells at once. Here is a list of actions and their 
results: 

Action Result 
Drag the mouse from one cell to another Selects an adjacent range between two cells 

Click one cell, press and hold Shift, then click 
another cell 

Selects an adjacent range between two cells 

Select a cell or range, press and hold CTRL, then 
select another cell or range using the drag method 

Selects a nonadjacent range of cells 

Click a column heading Selects all the cells in the column 

Click a row heading Selects all the cells in the row 

Click the upper-left corner of the worksheet (the 
blank gray cell between Column A and Row 1) 

Selects all the cells in the worksheet 

 

 

Entering Text 

To enter text, follow these steps: 

1. Move the cell pointer to the cell you want to enter text in. 

2. Begin typing. 
3. If you do not see text appear in the active cell, double-click and a blinking cursor should appear. 

You should now be able to enter text. 
4. If you enter a date, Excel will automatically adjust the format to look something like this: 

6/5/2007. You will find out how to change this format later. 
5. Excel aligns all numbers with the right side of the cell. Additionally, it is not necessary to add 

dollar signs or commas to numbers. This is a special formatting option you can use to format all 
numbers to have dollar signs and commas. Again, you will read more about this later. 

6. When you are done, press the Enter or Tab keys, or click another cell.  
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7. If you have entered a large amount of text in one cell, much of the text will seem to have 
disappeared when you move the cell pointer to a different cell. To confirm that your text is still 
there, move the cell pointer back to the cell with text. In the Formula toolbar, all the text 
entered in the cell will appear. 

8. If you enter so many numbers in a cell that they cannot all be displayed, your cell will look like 
this: 

 

 
 

You will read about adjusting cell width and height in Chapter Three. 
9. If you have entered a large amount of text in one cell, it will appear to be cut off. Click the Wrap 

Text icon in the Alignment group on the Home tab to have the cell resize itself vertically so 
that all text is visible. 
 

Editing and Deleting Text 

There are several ways to edit and delete text. Remember these rules when modifying text: 

 To edit data in a cell, double-click the cell and a blinking cursor will appear. Text or numbers will 
be inserted whenever the cursor is. If the cursor is placed between two characters, the text you 
type will appear between those characters. 

 To erase data entered in a cell, make sure it is the active cell and press the Delete key. 
 You can combine the Delete key with the keyboard functions listed above to delete greater 

amounts of text. 
 You can use the Backspace key to delete one character behind the cursor, or the Delete key to 

delete one character in front of the cursor. 
o You can select more than one character in a cell by clicking and dragging the cursor 

across each character. Once data is selected, any text typed using the keyboard will 
replace the selected text.  

 If a large block of text or multiple cells are selected when the Delete key is used, the entire 
selection will be deleted. 

 If a large block of text or multiple cells are selected when the Backspace key is used, only the 
first cell in the selection will be erased. 

 An additional way to erase a large group of cells is by selecting cells and using the fill handle to 
drag a gray area across the selected area. The fill handle appears as a small black square in the 
lower-right corner of a cell: 
 

 
 

Click the fill handle and drag it up and left across the selected cells. Your cells should look like 
this: 
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 When you let go of the mouse, the cells in gray will be erased. 

 

Hiding and Unhiding Rows and Columns 

Hiding columns and rows can be useful if you want to give only a part of a worksheet to someone else, 
or if you don’t want others to see certain cells in a worksheet without actually deleting anything. Note, 
however, that you cannot hide individual cells; only full rows and columns can be hidden.  

Follow these steps to hide cells: 

1. Make sure the row or column you want to hide is selected. 
2. Right-click anywhere in the selected area. In the drop-down menu that appears, click Hide. 

 

 
 

3. A thick black line will appear in place of the hidden row or column. Note also that the row 
number or column letter will disappear in the appropriate toolbar. When you click away from the 
column, the black line will disappear as well. 
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4. To unhide cells, select the columns or rows around the hidden ones. Right-click once again and 
choose Unhide from the drop-down menu. The hidden cells will appear once more. 

 
 
 

Using the Undo and Redo Features 

Many computer programs, including Microsoft Excel 2007, store recent changes you have made to a 
worksheet in the computer’s memory. If you have performed an action that you would like to reverse, 
simply click the Undo button. Similarly, if you have undone an action that you want to perform again, 
click the Redo button. Once you close the worksheet, Excel will no longer remember any changes you 
have made and the Undo/Redo features cannot be used. 

                            
 

 

To use the Undo button, follow these steps: 

 
1. On the Quick Access toolbar, find the Undo button. 

2. Click the down arrow next to the Undo button to display a list of actions you can reverse. 
3. Note that if you would like to undo an action that is in the middle of the list, you must undo all 

the actions listed before it first. 
4. Click the action you wish to reverse and the worksheet will update with the changes. 

5. If you want to reverse only the most recent action, you can simply click the Undo button without 
opening the Undo drop-down menu. 
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To use the Redo button, follow these steps: 

1. On the Quick Access toolbar, find the Redo button. 
2. The Redo button works the same way as the Undo button; simply click the drop-down arrow next 

to it to see a list of available actions you can perform. To repeat only the most recent action, you 
can click the Redo button without opening the drop-down menu. 

 
 
 

Copying and Pasting Text 

Using the cut, copy, and paste functions, you can move text in a worksheet from one location to 

another, or even move text from one worksheet to another. Cutting text removes selected cells and 
stores the information in the computer’s memory. Copying text stores selected cells in the computer’s 
memory without deleting it from the worksheet. Pasting text places cells that were previously cut or 
copied wherever the cursor is. 

 There are three methods for moving text: using the cut, copy, and paste functions on the Ribbon or 
Quick Access Toolbar, using the Office Clipboard, or using the drag-and-drop method. 
 

To use the Cut, Copy, and Paste functions, follow these steps: 

1. To cut a selection, highlight the area you want to cut and do one of three things: 
a. Right-click on the area and select Cut from the menu that appears 
b. Find the Cut command on the Clipboard group of the Home tab and click it 

 

 

c. Optionally, you can add the Cut icon to the Quick Access Menu for easy access 
2. To copy a selection, highlight the area you want to copy and do one of three things: 

a. Right-click on the area and select Copy from the menu that appears 

b. Find the Copy command on the Clipboard group of the Home tab and click it 
c. Optionally, you can add the Copy icon to the Quick Access Menu for easy access 

 

 

3. To paste a selection of text, move the cursor to where you want the pasted text to appear and 
do one of three things: 

a. Right-click and select Paste from the menu that appears 
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b. Find the Paste command on the Clipboard group of the Home tab and click it 
c. Optionally, you can add the Paste icon to the Quick Access Menu for easy access 
d. Note: if you copy more than one cell, the pasted selection will ensure that the data is 

spread across the same number of cells as were copied 
 

 
To use the Office Clipboard, follow these steps: 

 
The Office Clipboard is a task pane on the left side of the screen that stores multiple items that have 
been cut or copied. You can use the clipboard to paste items or to remove them from the copied list. 

1. To open the Office Clipboard, click the Dialog Box Launcher in the bottom-right corner of the 
Clipboard group on the Home tab. This will open the Office Clipboard Task Pane. 

2. Cut or copy a cell or group of cells and notice that the data appears in the Clipboard. 
3. In the Office Clipboard task pane, hover your mouse over one of the copied items. By clicking on 

the item, you can paste the data into the worksheet wherever the cell pointer is. 
4. When you hover your mouse over the item, you should notice that an arrow appears to the right 

of the item. Click on the arrow to reveal a drop-down list with the Paste and Delete commands. 
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5. To remove the copied item from the clipboard, click the Delete command. 
6. To paste all the items in the clipboard, select the Paste All button at the top of the clipboard.  

7. To delete all the items from the clipboard, select the Clear All button at the top of the clipboard. 
8. To close the Clipboard task pane, click the X in the upper-right corner. Note that closing the task 

pane does not delete copied text. 
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To use the drag-and-drop method, follow these steps: 

 
The drag-and drop method allows you to click and drag a cell or group of cells from one location to 
another. You can also copy cells using this method. In some cases, this can be faster than cutting or 
copying using the previous two methods.  
 

1. Select the cell or cells you wish to move. 
2. Move the cell pointer to the black border surrounding the cells. Your mouse should look like this: 

 

 

3. Click and drag the cell or cells to their new location. When you move your mouse, a light gray 
border will appear indicating the space your cells take up. When you have the cells in the right 
position, release your mouse. This should move the data in the cells to their new location. 

4. To copy text, select the cell or cells you wish to move. Move the cell pointer to the small black 
square in the lower-right corner of the selected cell or cells. Your mouse should turn into a black 
cross, known as the fill handle, that looks like this: 

 

 
 

5. Click and drag the cell or cells to the area you want them copied to. Note that cells copied using 
this method can only be moved to cell adjacent to the initial location of the copied cells. 

6. When you move your mouse, a light gray border will appear indicating where the cells will be 
copied. When you have the cells in the right position, release your mouse. This should copy the 
data to all the cells you selected with the gray border. 

 

 
 

Using the Page Break Preview View 

The Page Break Preview View is similar to the Print Preview feature you saw in Chapter One. Page 
Break Preview allows you view your worksheet as it would be seen when printed. In addition, you can 
use it to adjust the cut-off point for fitting cells on a printed page.  
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To use the Page Break Preview, follow these steps: 

1. Click the Page Break Preview icon in the Workbook Views group under the View tab. 
 

 

2. Your worksheet will open in a new view similar to that of the Print Preview feature. In this view, 
the text “Page One,” “Page Two,” and so forth appears in gray in the background. A blue 
dashed line indicates a break between two pages vertically, while a sold blue line indicates a 
break between two pages horizontally. 
 

 

3. To adjust the page breaks, hover your mouse anywhere on one of the blue lines. When your 
mouse turns into a pointed arrow, click and drag the line. Release the mouse when you have the 

break you want. Cells that no longer appear on the page appear with a gray background. 
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4. To exit the Workbook View group and click Normal.  
5. Note that once you have adjusted page breaks, black dashed lines appear in your worksheet 

indicating the breaks. 
 
 
 

Using the Page Layout View 
 
The Page Layout View in Excel 2007 is lifted from the Print Layout View in Microsoft Word. This view 
allows you to see the worksheet as it appears on a printed page, much like the Print Preview view. 

To use Page Layout View, follow these steps: 

1. Click the Page Layout icon in the Workbook Views group on the View tab. 

2. In this view, you can use the Show/Hide group to turn on or off rulers, gridlines, headings, 
and the formula bar. 

3. To return to the Normal View, click the Normal icon in the Workbook Views group. 
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